Twitter Data
Incident Report for Gavagai
Resolved
This incident has been resolved.
Posted Nov 20, 2015 - 15:09 CET
Investigating
We're currently experiencing problems with our incoming Twitter data.
Posted Nov 20, 2015 - 13:41 CET