Temporary System Downtime
Incident Report for Gavagai
Resolved
The issue has been resolved. We will continue to monitor closely and will update if needed.
Posted Feb 26, 2018 - 14:19 CET
Investigating
We are aware of the problem and working on the fix right now.
Posted Feb 26, 2018 - 11:15 CET