Temporary System Instability
Incident Report for Gavagai
Resolved
We will continue to monitor closely and will update if needed.
Posted Feb 26, 2018 - 10:34 CET
Investigating
We are aware of the problem and working on the fix right now.
Posted Feb 26, 2018 - 10:21 CET