Server problems creating problems for some users.
Incident Report for Gavagai
Resolved
This incident has been resolved.
Posted Nov 27, 2017 - 15:06 CET
Investigating
We are currently experiencing runtime errors with the Explorer as a result of a temporary memory issue in the back end. We are working on a solution and normal service should resume later this afternoon.
Posted Nov 27, 2017 - 13:45 CET